IPC з Ruby 1.8.5 - ruby, ipc, sketchup

Мені потрібно зробити IPC з Ruby 1.8.5. Схоже, що це Ruby, що поставляється разом із Google SketchUp, і є лише підмножиною повного API Ruby. Так, наприклад, у ньому немає класу Socket і DRB немає.

Який інший спосіб зробити IPC з Ruby?Усе, що використовує клас Файл, як-от файли, накладені на пам'ять чи щось подібне? Я абсолютно новий для IPC, тому я пробачусь, якщо я пропустив щось очевидне.

Відповіді:

0 для відповіді № 1

Остання версія SketchUp поставляється з Ruby 1.8.6. Ви можете завантажити (якщо ви ще не є) основним API Ruby, а просто require які файли вам потрібні, для реалізації вашого сценарію.

Тестування не-SketchUp Ruby-коду, набагато простіше за межами SketchUp, за допомогою командного рядка або редактора, як SciTE. Потім ви можете додати свій код SketchUp для тестів у програмі.

Ruby Завантажити

SciTE Завантажити


Схожі запитання
Найбільш популярний