Ruby requer erros - ruby, ubuntu, gem, require

Requer gemas instaladas não são visíveis.

Teste com hpricot que instalei várias vezes:

irb(main):001:0> require "rubygems"
=> false
irb(main):002:0> require "hpricot"
LoadError: no such file to load -- hpricot
from (irb):2:in `require"
from (irb):2
from /usr/bin/irb:12:in `<main>"
irb(main):003:0>

Ambiente RubyGems:

RubyGems Environment:
- RUBYGEMS VERSION: 1.3.7
- RUBY VERSION: 1.9.2 (2010-07-02 patchlevel -1) [i486-linux]
- INSTALLATION DIRECTORY: /var/lib/gems/1.9.2
- RUBY EXECUTABLE: /usr/bin/ruby1.9.2
- EXECUTABLE DIRECTORY: /var/lib/gems/1.9.2/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86-linux
- GEM PATHS:
- /var/lib/gems/1.9.2
- /root/.gem/ruby/1.9.2
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://rubygems.org/

Eu tenho várias versões do Ruby instalado (backtrack 5r2)

[email protected]:/home/targeex/Stage/Application_Wissam# update-alternatives --config ruby
There are 2 choices for the alternative ruby (providing /usr/bin/ruby).

Selection    Path                Priority   Status
------------------------------------------------------------
0            /usr/bin/ruby1.8     600       auto mode
1            /usr/bin/ruby1.8     600       manual mode
* 2            /usr/bin/ruby1.9.2   400       manual mode

Press enter to keep the current choice[*], or type selection number: 2

o que eu posso fazer?

Respostas:

2 para resposta № 1

Parece que você não instalou a gema no rubi certo. Se você puder, mude para o uso do RVM (https://rvm.io/), ele irá curar o que o aflige.


Cardápio