Erro de compilação com ios-charts - ios, swift, ios-frameworks, ios-charts

Eu segui o guia Aqui para instalar o quadro ios-charts como umbinário incorporado e a etapa 3 do guia instrui-me a criar o projeto. A construção falha instantaneamente como resultado da adição do binário incorporado. Eu baixei a versão mais recente do framework, e supostamente compatível com o swift 3.

Eu estou usando X-code 8 beta e, portanto, rápido 3. Alguém pode me apontar na direção certa?

insira a descrição da imagem aqui

Respostas:

2 para resposta № 1
  1. Baixar arquivo zip com projeto

  2. Construa

  3. No Xcode, localize a pasta do produto, encontre lá Gráficos do produto, mostre no Finder
  4. Abra seu projeto no xCode
  5. Arrastar e soltar o bundle (da etapa 3) para o seu projeto no xCode
  6. Defina as configurações do seu projeto: em Binários embarcados use "+" para adicionar gráficos

0 para resposta № 2

1) Use CocoaPods (doc: https://cocoapods.org)

2) Adicione gráficos ao seu arquivo pod (doc: https://github.com/danielgindi/Charts)

Adicione pod "Gráficos" ao seu Podfile. "Gráficos" é o nome da biblioteca.

Para suporte a Realm, você pode especificar a subespecificação no seu Podfile da seguinte maneira:

pod "Gráficos / Reino"

Nota: pod "ios-charts" não é a biblioteca correta, e refere-se a um projeto diferente de outra pessoa.


-1 para resposta № 3

Para o Swift 3, você deve ir com o CocoaPods.

Escreva pod "Charts/Realm" Isso instalará a versão exata do pod para o gráfico e, em seguida, limpará e criará.


Cardápio