Selenium IDE 2.5.0との互換性のあるバージョンは何ですか? - セレン、ジュニット、セレン-rc、セレン - イデア

私はセレンide 2.5をインストールしました。Java / JUnit 4 / Web Driverとしてテストケースをエクスポートした後、Firefox用のアドオンを追加しました。私がJUnitのテストでそれを実行しようとすると、セレンのクラスが見つからないときに例外が発生します。私はselenium-api-4.2.0.jarとselenium-server-stendalone-2.42.2.jarを使用しました。私はselenium-api-4.2.0.jarからselenium-api-2.42.2.jarに切り替えることも試みましたが、常にクラスがありません。 2.5.0 IDE用に使用する正しいselenium-apiとselenium-server-stendalone Jarはどちらですか? アドバンスのThnx

回答:

回答№1は0

この ドキュメンテーションのグラフィック どのようにすべての瓶が互いに関連しているかを示します。 selenium-server-standaloneにはそれ自身とすべての依存関係がすべて含まれています。

Selenium IDEはSelenium-RC APIを使用するコードをエクスポートせず、Selenium WebDriver APIのみを使用します。

一般的に、あなたが何か非常に特別なことをしていない限り、最新のすべての安定版を使いたいと思う。

それでも問題が解決しない場合は、 このコードを投稿し、エラーメッセージを投稿してください。


メニュー
最も人気のある