セレン3 + JBehave? - java、selenium、selenium-webdriver、jbehave、selenium3

誰も使用しますか? JBehave 〜と selenium 3.0 ?アップグレードのように見える selenium バージョンを3.0に変更 JBehave 動作を停止します。

すべての問題は約です -

"java.lang.NoClassDefFoundError:com / thoughtworks / selenium / condition / ConditionRunner"、

このクラスが削除されたようです selenium 3.0。 何か回避策はありますか?

たとえば、

package org.jbehave.web.selenium;

public SeleniumPage(Selenium selenium, ConditionRunner conditionRunner)
{
this.selenium = selenium;
this.conditionRunner = conditionRunner;
})

回答:

回答№1は0

さて、私はJBehave開発者から答えを得ました:

「Selenium 3.0をサポートするJBehave Web 4.0ブランチを開始する必要があります」

だから今のところこの問題とは何の関係もないようです。


関連する質問
メニュー
最も人気のある