IPC con Ruby 1.8.5 - ruby, ipc, sketchup

Devo fare IPC con Ruby 1.8.5. Il problema è che è il Ruby che viene fornito con Google SketchUp ed è solo un sottoinsieme dell'intera API di Ruby. Ad esempio, non esiste una classe Socket e nessun DRb.

Quali sono altri modi di fare l'IPC con Ruby?Qualcosa che usa la classe File, come i file mappati in memoria, o qualcosa del genere? Sono completamente nuovo a IPC, quindi mi scuso se ho perso qualcosa di ovvio.

risposte:

0 per risposta № 1

L'ultima versione di SketchUp viene fornita con Ruby 1.8.6. Puoi scaricare (se non lo hai già fatto) l'API core di Ruby, e solo require qualunque file sia necessario, per implementare il tuo script.

Test di codice Ruby non di SketchUp, è molto più semplice al di fuori di SketchUp, con la riga di comando o un editor come SciTE. Quindi puoi aggiungere il tuo codice SketchUp per i test all'interno dell'applicazione.

Scarica Ruby

Scarica SciTE


Menu