खराब दुभाषिया: गिट बैश से रूबी चलाने पर अनुमति अस्वीकार कर दी गई - खिड़कियां, गिट, मणि

$ gem install jekyll
sh.exe": /c/ruby/bin/gem: C:/ruby/bin: bad interpreter: Permission denied

जब मैं गिट बैश में मणि इंस्टॉल jekyll चला रहा हूँ, जो मुझे बता सकता है कि अनुमति कैसे बदलें।

ओएस विंडोज एक्सपी है।

आपका बहुत बहुत धन्यवाद!

    RubyGems Environment:
- VERSION: 0.9.4 (0.9.4)
- INSTALLATION DIRECTORY: c:/ruby/lib/ruby/gems/1.8
- GEM PATH:
- c:/ruby/lib/ruby/gems/1.8
- REMOTE SOURCES:
- http://gems.rubyforge.org

उत्तर:

जवाब के लिए 0 № 1

वर्तमान उपयोगकर्ता को माणिक फ़ोल्डर के स्वामित्व को बदलने का प्रयास करें।

या राइट-क्लिक करके cmd को व्यवस्थापक के रूप में खोलने का प्रयास करें cmd -> run as administrator


जवाब के लिए 0 № 2

मुझे अपने विंडोज 7 पर एक ही समस्या थीवातावरण। मुझे कोट्स में RoR से जुड़े सभी पथों को शामिल करके पाथ पर्यावरण परिवर्तक को बदलना पड़ा। विशेष रूप से निम्न पथ: ...; सी: / प्रोग्राम फ़ाइलें (x86) ... को एकीकृत किया गया था ...; "सी: / प्रोग्राम फ़ाइलें (x86) ...";

यह मेरे लिए मुद्दा तय किया। आशा करता हूँ की ये काम करेगा।


संबंधित सवाल
सबसे लोकप्रिय