सिम्फनी 3 अपडेट निर्भरता संघर्ष - सिम्फनी, निर्भरता, संगीतकार-php, symfony-2.7, symfony3.x

जब मैं एक संगीतकार चलाता हूं, तो सिम्फनी 2.7 से 3.x तक प्रोजेक्ट को अपडेट करने का प्रयास कर रहा हूं अद्यतन करें मुझे अलग-अलग बंडलों के बीच निर्भरता संघर्ष मिलते हैं जो मैं उपयोग कर रहा हूं, उदाहरण के लिए:

friendsofsymfony/jsrouting-bundle 1.5.3 requires symfony/framework-bundle ~2.0
lunetics/locale-bundle 2.4.5 requires symfony/framework-bundle ^2.8|^3.0

तथा

symfony/framework-bundle 3.3.x-dev conflicts with symfony/symfony[v3.0.0]

क्या बंडलों को अक्षम किए बिना संघर्ष को सुलझाने के लिए कोई कामकाज है?

मेरी composer.json फ़ाइल: https://pastebin.com/tAsij64M

उत्तर:

जवाब के लिए 0 № 1

आपको अपडेट करना होगा:

  • फ्रेमवर्क-बंडल 3 के साथ संगत होने के लिए jsrouting-bundle ^ 1.6 तक। *
  • सिम्फनी 3.3 या डाउनग्रेड फ्रेमवर्क-बंडल 3.0 तक। * क्योंकि सिम्फनी और फ्रेमवर्क-बंडल का एक ही संस्करण होना चाहिए

संबंधित सवाल
सबसे लोकप्रिय