रूबी: जूते स्थापित हैं लेकिन हैलो वर्ल्ड प्रोग्राम काम नहीं करता है - रूबी, जूते

मैंने जूते मणि स्थापित किए लेकिन मैं इसका उपयोग नहीं कर सकता:

> gem install green_shoes
Successfully installed green_shoes-1.1.374
Parsing documentation for green_shoes-1.1.374
unable to convert "xA9" from ASCII-8BIT to utf-8 for lib/shoes/minitar.rb, skipping
Done installing documentation for green_shoes after 1 seconds
1 gem installed

[email protected] C:UsersolivierDocumentsruby
> irb
irb(main):001:0> require "green_shoes"
LoadError: cannot load such file -- gobject-introspection
from C:/Ruby23-x64/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require"
from C:/Ruby23-x64/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require"
from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/gdk_pixbuf2-3.0.9-x64-mingw32/lib/gdk_pixbuf2.rb:17:in `<top (require
d)>"
from C:/Ruby23-x64/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require"
from C:/Ruby23-x64/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require"
from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/green_shoes-1.1.374/lib/green_shoes.rb:5:in `<top (required)>"
from C:/Ruby23-x64/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:133:in `require"
from C:/Ruby23-x64/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:133:in `rescue in require"
from C:/Ruby23-x64/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:40:in `require"
from (irb):1
from C:/Ruby23-x64/bin/irb.cmd:19:in `<main>"

क्या कोई इस मुद्दे को ठीक करने में मेरी मदद कर सकता है?

धन्यवाद

ओलिवियर

संपादित करें:

मैंने 2 रत्न स्थापित किए, लेकिन एक साधारण डेमो प्रोग्राम (जो "आवश्यकता" green_shoes "" से शुरू होता है, यह त्रुटि देता है:

रूबी test1.rb सी: /Ruby23/lib/ruby/site_ruby/2.3।0 / rubygems / specification.rb: 2288: में `raise_if_conflicts": सक्रिय करने में असमर्थ gobject-introspection-3.0.8-x86-mingw32, क्योंकि glib2-3.0.9-x86-mingw32 glib2 के साथ संघर्ष (= 3.0.8) (रत्न :: ConflictError)

कार्यक्रम यहाँ है:

require "green_shoes"

puts "hello world"

puts Math.sqrt(9)

def say_hi(name="!")
puts "hello world #{name}"
end

say_hi("Olivier")
say_hi

class Greeter
def initialize(name)
@name=name

end

def say_hello
puts "hello #{@name.capitalize}"
end

def to_s
"I said hello!"
end


end

g=Greeter.new("olivier")
g.say_hello
puts g
# hello_world.rb


Shoes.app do
para "Hello World"
end

Shoes.app { button "Push me" }

यह एक परीक्षण कार्यक्रम है, इसमें महत्वपूर्ण चीजें नहीं हैं।

ओलिवियर

ps: मैं glib2 के 2 संस्करणों के बीच संघर्ष को समझता हूं, लेकिन मुझे किस संस्करण को हटाने के बारे में संकोच है: मैं अपनी रूबी स्थापना को तोड़ना नहीं चाहता हूं। मुझे कौन सा हटाना चाहिए?

EDIT2:

वहाँ अभी भी एक मुद्दा है: green_shoes को पेंगो और कैरो की स्थापना की आवश्यकता है, लेकिन अन्य संस्करणों की 3.0.8:

मणि अनइंस्टॉल glib2 -v 3.0.9
आपने मणि को अनइंस्टॉल करने का अनुरोध किया है:
glib2-3.0.9-86-mingw32
एटीके 3.0.9 glib2 पर निर्भर करता है (= 3.0.9)
gdk_pixbuf2-3.0.9 glib2 (= 3.0.9) पर निर्भर करता है
पेंगो-3.0.9 glib2 (= 3.0.9) पर निर्भर करता है यदि आप इस मणि को हटा दें, इन निर्भरताओं को पूरा नहीं किया जाएगा।

मुझे नहीं पता कि मुझे कैसे करना चाहिए ... आपको ग्रीन_शोज़ का कौन सा संस्करण मिला है?

धन्यवाद

ओलिवियर

पुनश्च:मैंने बस आपके बाकी संपादन को देखा; स्ट्रैज चीज यह है कि मुझे तुम्हारी तुलना में green_shoes का एक ही संस्करण मिला है ... लेकिन मेरे लिए glib2-3.0.9 स्थापित किया गया था, और आपके लिए glib2 3.0.8 .... मैंने सोचा था कि green_shoes, और इसकी निर्भरताओं को हटा दें, फिर 3.0.8 संस्करण में कुछ निर्भरताओं को स्थापित करें, फिर green_shoes इंस्टॉल करें और उम्मीद करें कि इसकी निर्भरता के 3.0.9 संस्करणों की आवश्यकता नहीं है ... तुम उसके बारे में क्या सोचते हो?

EDIT3:

सूंघना! मैं यही डरता था!

green_shoes की स्थापना का परिणाम यहां दिया गया है:

    > gem install green_shoes
Fetching: glib2-3.0.9-x86-mingw32.gem (100%)
Successfully installed glib2-3.0.9-x86-mingw32
Fetching: green_shoes-1.1.374.gem (100%)
Successfully installed green_shoes-1.1.374

और अब मेरे पास glib2 के 2 संस्करण हैं (3.0.8 और 3.0.9)

EDIT4:

मैं कुछ भी समझ नहीं पा रहा हूं: इसे देखो:

मणि सूची glib2

* स्थानीय गेम्स * glib2 (3.0.9 x86-mingw32)
[ईमेल संरक्षित] सी: UsersolivierDocumentsruby

रूबी टेस्ट 2।आरबी सी: /Ruby23/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb: 2288: में `raise_if_conflic ts": सक्रिय करने में असमर्थ gobject-introspection-3.0.8-x86-mingw32, क्योंकि glib2-3.0.9-x Glib2 (= 3.0.8) के साथ 86-mingw32 संघर्ष (जेम :: ConflictError)

मैंने glib2 v 3.0.8 हटा दिया लेकिन अभी भी एक संघर्ष है ...

EDIT5:

मैंने आपकी सलाह का पालन किया, और संस्करण 3.0.9 हटा दिया, लेकिन आश्चर्यजनक रूप से ऐसा लगता है कि संस्करण 3.0.8 अभी भी आवश्यक है:

रूबी test2.rb सी: /Ruby23/lib/ruby/site_ruby/2.3.0/rubygems/dependency.rb: 310: में to_specs": Could not find "glib2" (= 3.0.9) - did find: [glib2-3.0.8-x86-mingw32] (Gem::MissingSpecVersionError) Checked in "GEM_PATH=C:/Users/olivier/.gem/ruby/2.3.0;C:/Ruby23/lib/ruby/gems/2.3.0", executeअधिक जानकारी के लिए मणि env`

हालांकि मैंने अपनी 3.0.8 निर्भरताओं को हटा दिया, और 3.0.9 रहने दिया। अभी भी, मैं समझ में नहीं आता

उत्तर:

उत्तर № 1 के लिए 1

मैंने हाल ही में विंडोज 7 के तहत हरे रंग के जूते को फिर से स्थापित कियाऔर रूबी 2.3.0 और मुझे कोई कठिनाई नहीं थी, यहां मेरे सिस्टम पर उपयोग किए जाने वाले जीडीके संस्करण हैं। इस संस्करण को निर्दिष्ट करते समय उन्हें अलग स्थापित करें। यदि आवश्यक हो तो पता नहीं है लेकिन हमेशा आपके पथ में देवकिट रखने की सलाह दी जाती है।

संस्करण:

gdk3 (3.0.8 x64-mingw32)
gdk_pixbuf2 (3.0.8 x64-mingw32)

उन्हें स्थापित करें

gem install gdk3 -v 3.0.8
gem install gdk_pixbuf2 -v 3.0.8

संपादित करें

मेरा ग्लिब संस्करण निम्नानुसार है, मेरा सुझाव है कि आप अपने वर्तमान संस्करण को जांचें gem list glib2, इसे नोट करें, मेरा संस्करण स्थापित करें और यदि चीजें तोड़ती हैं तो आप हमेशा glib2 को अनइंस्टॉल कर सकते हैं और पुराने संस्करण को पुनर्स्थापित कर सकते हैं।

glib2 (3.0.8 x64-mingw32)

निम्नलिखित कमांड को सभी निर्भरताओं को सूचीबद्ध करना चाहिए, लेकिन यह फिर से शुरू नहीं होता है, इसलिए मुझे किसी भी गहरे जाने की आवश्यकता होने पर मुझे बताएं।

C:UsersGebruiker>gem dependency green_shoes --reverse-dependencies
Gem green_shoes-1.1.374
gtk2 (>= 0)



C:UsersGebruiker>gem dependency gtk2 --reverse-dependencies
Gem gtk2-3.0.8-x64-mingw32
atk (= 3.0.8)
gdk_pixbuf2 (= 3.0.8)
pango (= 3.0.8)
Used by
green_shoes-1.1.374 (gtk2 (>= 0))

Gem pango-3.0.8-x64-mingw32
cairo (>= 1.14.0)
glib2 (= 3.0.8)
Used by
gdk3-3.0.8-x64-mingw32 (pango (= 3.0.8))
gtk2-3.0.8-x64-mingw32 (pango (= 3.0.8))
gtk3-3.0.8-x64-mingw32 (pango (= 3.0.8))
rsvg2-3.0.8-x64-mingw32 (pango (>= 3.0.8))

EDIT2

मैं उपयोग करके एक पूर्ण निर्भरता पेड़ पाने में कामयाब रहे इस उत्तर

{"green_shoes 1.1.374"=>
{"gtk2 3.0.8"=>
{"gtk2 3.0.8"=>
{"atk 3.0.8"=>
{"atk 3.0.8"=>
{"glib2 3.0.8"=>
{"glib2 3.0.8"=>
{"pkg-config 1.1.7"=>{"pkg-config 1.1.7"=>{}},
"cairo 1.15.2"=>
{"cairo 1.15.2"=>
{"pkg-config 1.1.7"=>{"pkg-config 1.1.7"=>{}}}}}}}},
"pango 3.0.8"=>
{"pango 3.0.8"=>
{"cairo 1.15.2"=>
{"cairo 1.15.2"=>{"pkg-config 1.1.7"=>{"pkg-config 1.1.7"=>{}}}},
"glib2 3.0.8"=>
{"glib2 3.0.8"=>
{"pkg-config 1.1.7"=>{"pkg-config 1.1.7"=>{}},
"cairo 1.15.2"=>
{"cairo 1.15.2"=>
{"pkg-config 1.1.7"=>{"pkg-config 1.1.7"=>{}}}}}}}},
"gdk_pixbuf2 3.0.8"=>
{"gdk_pixbuf2 3.0.8"=>
{"glib2 3.0.8"=>
{"glib2 3.0.8"=>
{"pkg-config 1.1.7"=>{"pkg-config 1.1.7"=>{}},
"cairo 1.15.2"=>
{"cairo 1.15.2"=>
{"pkg-config 1.1.7"=>{"pkg-config 1.1.7"=>{}}}}}}}}}}}}

संबंधित सवाल
सबसे लोकप्रिय