आप पहले ही रैक 1.3.2 सक्रिय कर चुके हैं, लेकिन आपके जेमफाइल को रैक 1.2.3 की आवश्यकता है। बंडल निष्पादन - रूबी, यात्री, रैक का उपयोग करने पर विचार करें

जब मैं अपना ऐप चलाने की कोशिश कर रहा हूं तो मुझे एक समस्या हुई:

You have already activated rack 1.3.2, but your Gemfile requires rack 1.2.3. Consider using bundle exec.

मैंने इस तरह की त्रुटि के बारे में बहुत कुछ पढ़ा, लेकिन मुझे ऐसा कोई हल नहीं मिला जो मेरे लिए काम करता हो

  • मैंने पहले ही अपना Gemfile.lock निकाल दिया और सुझाव के अनुसार बंडल फिर से चलाया यहाँ
  • मैं पहले से ही यात्री के नवीनतम संस्करण (3.0.8) का उपयोग करता हूं - जैसा कि सुझाव दिया गया है यहाँ
  • The bundle exec rake छल मेरे मामले में इस्तेमाल नहीं किया जा सकता

अग्रिम प्रति धंयवाद

उत्तर:

उत्तर № 1 के लिए 4

रन bundle install --binstubs और आप पाएंगे बिन अनुप्रयोग द्वारा आवश्यक सभी निष्पादन योग्य के साथ अपने आवेदन जड़ में निर्देशिका.

उसके बाद आप इस dir पथ और यह करने के लिए सबसे अच्छी जगह पर जोड़ने के लिए की आवश्यकता है - .rvmrc यदि आप RVM का उपयोग करें।

[ -d "./bin" ] && export PATH=`pwd`/bin:$PATH

या बस अपने अनुप्रयोग रूट से ./bin/[rake[rails[etc] चलाने के लिए।


जवाब के लिए 3 № 2

बंडल exec, यानी के साथ अपने सर्वर को चलाने के लिए आदेश prefixing का प्रयास करें.

bundle exec rails server

या उत्पादन में (यदि आप गेंडा की तरह कुछ का उपयोग कर रहे हैं

bundle exec unicorn [options]

संबंधित सवाल
सबसे लोकप्रिय