एक रूबी 1.8.7 सिस्टम पर पेपरक्लिप मणि कैसे स्थापित करें? - रूबी-ऑन-रेल, रूबी, पेपरक्लिप, रेल-आई 18 एन

मुझे रूबी 1.8.7 / रेल 2.3.15 के लिए लिखा गया एक ऐप मिला है और मैं पेपरक्लिप के साथ फंस गया हूं। जब मैं मणि स्थापित करने की कोशिश करता हूं तो मुझे मिलता है:

> ~$ gem install paperclip
ERROR:  Error installing paperclip:
i18n requires Ruby version >= 1.9.3.

जब मैं i18n (0.6.x) का 1.8.7 संगत संस्करण स्थापित करता हूं तो मुझे एक ही त्रुटि मिलती है।

मैंने यहां कुछ जवाब देखा>रूबी 1.7.7 पर पेपरक्लिप 2.7.0, लेकिन यह एक कदम आगे है (उसे सक्रिय समर्थन के साथ समस्याएं मिली हैं) और उत्तर (खुद को मणि बनाएं) मेरी क्षमताओं से परे है।

क्या कोई एक व्यवहार्य समाधान सुझा सकता है (ऐप को 1.9.3 तक अपग्रेड करना सवाल से बाहर है)?

उत्तर:

उत्तर № 1 के लिए 1

मैंने इसे खुद समझ लिया:बस मणि इंस्टॉल के साथ -f विकल्प का उपयोग करें और यह निर्भरताओं के बावजूद इसे इंस्टॉल करेगा। सबको धन्यवाद। और, हाँ, मुझे पता है कि संस्करण पुराना और पुराना और असुरक्षित है, आदि कौन परवाह करता है, यह काम करता है :)


संबंधित सवाल
सबसे लोकप्रिय