रूबी 2.3.0 - चेतावनी: परिपत्र तर्क संदर्भ - अब - रूबी-ऑन-रेल

चलने पर rake db:migrate, मुझे निम्न त्रुटि मिल रही है।

/var/lib/gems/2.3.0/gems/activesupport-3.1.0/lib/active_support/values/time_zone.rb7268: चेतावनी: परिपत्र तर्क संदर्भ - अब

उत्तर:

जवाब के लिए 0 № 1

यह तब हो सकता है जब आप रूबी संस्करण का उपयोग करते हैं जो आपके पास रेल के संस्करण के लिए बहुत नया है। रेल को उच्च संस्करण में अपडेट करने का प्रयास करें।

रेल साइट से सामान्य दिशानिर्देश यहां दिए गए हैं:

रेल 5 को रूबी 2.2.2 या नए की आवश्यकता होती है।

रेल 4 रूबी 2.0 पसंद करते हैं और 1.9.3 या नए की आवश्यकता होती है।

रेल 3.2.x रूबी 1.8.7 का समर्थन करने वाली आखिरी शाखा है।

रेल 3 और ऊपर रूबी 1.8.7 या उच्चतम की आवश्यकता होती है। पिछले सभी रूबी संस्करणों के लिए समर्थन आधिकारिक तौर पर गिरा दिया गया है। आपको जितनी जल्दी हो सके अपग्रेड करना चाहिए।


संबंधित सवाल
सबसे लोकप्रिय