jupyter प्रयोगशाला टूट गई है मैं इसे कैसे ठीक कर सकता हूँ? - पायथन, पायथन-3.x, जिप्टर-नोटबुक, पायथन-3.6, जिप्टर-लैब

मैं यह नहीं समझ सकता कि क्यों जुपीटर-प्रयोगशाला काम नहीं कर रही है। कुछ टूटा हुआ है और कहां नहीं है। मैंने इसके लिए वेब खोजा है और कोई समाधान नहीं ढूंढ सकता। कृपया आप मदद करें। इसकी सराहना करें।

ई: gitrepos> jupyter प्रयोगशाला

`Traceback (most recent call last):
File "E:anaconda3Scriptsjupyter-lab-script.py", line 3, in <module>
import jupyterlab.labapp
File "E:anaconda3libsite-packagesjupyterlablabapp.py", line 7, in <module>
from notebook.notebookapp import NotebookApp, aliases, flags
File "C:UsersDario.RomeroAppDataRoamingPythonPython35site-packagesnotebooknotebookapp.py", line 78, in <module>
from .services.kernels.kernelmanager import MappingKernelManager
File "C:UsersDario.RomeroAppDataRoamingPythonPython35site-packagesnotebookserviceskernelskernelmanager.py", line 19, in <module>
from jupyter_client.session import Session
File "E:anaconda3libsite-packagesjupyter_clientsession.py", line 61, in <module>
from jupyter_client.jsonutil import extract_dates, squash_dates, date_default
File "E:anaconda3libsite-packagesjupyter_clientjsonutil.py", line 11, in <module>
from dateutil.parser import parse as _dateutil_parse
ImportError: No module named "dateutil.parser"`

उत्तर:

जवाब के लिए 0 № 1

आपको स्थापित करने की आवश्यकता है dateutil पुस्तकालय: https://pypi.python.org/pypi/python-dateutil/

(यदि आपने पैकेज प्रबंधक का उपयोग किया है, तो जुपीटरलैब के लिए निर्भरता पहले से ही स्थापित होनी चाहिए। अगर आपने नहीं किया है, तो आपको निर्भरताओं को स्वयं स्थापित करना होगा।)


संबंधित सवाल
सबसे लोकप्रिय