Zend_search_lucene का उपयोग करने के लिए क्या मुझे अपने PHP एप को एमवीसी में परिवर्तित करना है? - php, mysql, zend-framework, zend-search-lucene

I have finished writing my own web application अभी व। यह PHP में MYSQL डीबी के साथ लिखा गया है और मैंने किसी भी एमवीसी ढांचे का उपयोग नहीं किया है। अब मैं अपने ऐप के लिए स्थानीय खोज कार्यक्षमता जोड़ना चाहता हूं और यहां अन्य पोस्ट देखने से, Zend_Search_Lucene मेरे लिए एक अच्छा विकल्प प्रतीत होता है।

अब अगर मैं Zend_Search_Lucene का उपयोग करना चाहता हूं तो मुझे पूरे ज़ेंड फ्रेमवर्क को स्थापित करना होगा, फिर मेरे ऐप को दोबारा लिखना होगा और उन्हें अपने एमवीसी ढांचे में अनुकूलित करना होगा?

मैं बस खोज की सुविधा का उपयोग करने के लिए देख रहा हूँढांचा, और अभी मैं शायद पूरी ढांचे को स्थापित करने में वास्तव में बुरा नहीं मानता, लेकिन मुझे निश्चित रूप से करना है अगर मुझे अपने ऐप में बड़े पैमाने पर परिवर्तन करना है ..

किसी भी उत्तर-सुझाव, thx की सराहना करते हैं

उत्तर:

उत्तर № 1 के लिए 4

You can just use the Zend_Search_Lucene package, आपको पूरे ढांचे और / या एमवीसी पहलू का उपयोग करने की आवश्यकता नहीं है। अगर आप पूरे ढांचे को स्थापित नहीं करना चाहते हैं, तो आपको पैकेज निर्भरताओं की जांच करनी होगी जो Zend_Search_Lucene है। ऐसा करने के कुछ स्वचालित तरीके हैं, यहां कुछ हैं:

यदि आप इसे Google करते हैं तो आपको निश्चित रूप से और अधिक मिल जाएगा।


उत्तर № 2 के लिए 1

प्रश्न के उत्तर के लिए: नहीं, आपको इसे बदलना नहीं है, आप स्वतंत्र रूप से ज़ेंड फ्रेमवर्क पुस्तकालयों का उपयोग कर सकते हैं।

हालांकि, मैंने आपको लुसीन पर कोई ट्यूटोरियल नहीं दिया, हालांकि।


संबंधित सवाल
सबसे लोकप्रिय