केवल IE8 में jQuery त्रुटि 'ऑब्जेक्ट इस संपत्ति या विधि का समर्थन नहीं करता है' - jquery

मैं उपयोग कर रहा हूँ jQuery v2.0.1 एक वेब पेज पर जिसमें ग्रिड होता है, और वहां होता हैपाद लेख पर एक "खोज" छवि बटन। Grid_RowCommond ईवेंट पर, मैं पॉप अप में खोज परिणाम दिखाने के लिए निम्न स्क्रिप्ट का उपयोग करूंगा, और जब उपयोगकर्ता खोज परिणामों में से किसी एक पर क्लिक करेंगे, तो चयनित परिणाम पैरेंट पेज पर पाद लेख पंक्ति पर वापस आ जाएगा और पॉप अप होगा बन्द है। मैंने आईई 10 पर इस फ़ंक्शन का परीक्षण किया, जो उपयोगकर्ता प्रतिक्रिया के पूरी तरह से काम करता है जब उन्होंने IE8 के नीचे जावास्क्रिप्ट त्रुटि देखी।

क्रिप्या मेरि सहायता करे।

protected void grid_RowCommand(object sender, GridViewCommandEventArgs e)
{
if (e.CommandName == "Search")
{
TextBox txtNo = grid.FooterRow.FindControl("txtNo") as TextBox;

System.Text.StringBuilder s = new System.Text.StringBuilder();
s.Append("<script language="javascript" id="SearchResult"> " );
s.Append("var WinSettings = "dialogHeight:400px ; dialogWidth: 550px ;center: Yes ;resizable: No;status: no"; ");
s.Append("javascript: var windowReturnValue =window.showModalDialog("Search.aspx?car_no=" + txtNo.Text.Trim().ToUpper() + "","",WinSettings);");

s.Append("$("#" + txtNo.ClientID + "").val(windowReturnValue) ;");
s.Append("</script > ");

if ((!ClientScript.IsStartupScriptRegistered("SearchResult")))
{
ClientScript.RegisterStartupScript(this.GetType(), "SearchResult", s.ToString());
}
}
}

उत्तर:

जवाब के लिए 0 № 1

jQuery 2.x ने IE8 समर्थन हटा दिया है, jQuery के बजाय सबसे स्थिर 1.x स्थिर संस्करण का उपयोग करें; 1.10.2


जवाब के लिए 0 № 2

Jquery 2. एक्स आईई 8 समर्थन गिरा दिया

संदर्भ के लिए कृपया नीचे दिए गए लिंक का संदर्भ लें

http://jquery.com/browser-support/


संबंधित सवाल
सबसे लोकप्रिय