रेक संपत्ति: प्रीकंपाइल काम नहीं कर रहा है - विंडोज 7 - सीएसएस, रूबी-ऑन-रेल, रूबी, विंडोज़, कंपाइलर-त्रुटियां

मुझे मेरी सीएसएस फाइलों और कैश में समस्याएं आ रही हैं। स्टाइल शीट में से कोई भी अब लोड नहीं लग रहा है, और मैंने पढ़ा है कि मैं इसका उपयोग करने का प्रयास कर सकता हूं rake assets:precomile, लेकिन मुझे एक त्रुटि मिलती है।

जब मैं ट्रेस के साथ दौड़ता हूं:

C:UsersadminDesktopwebapp>rake assets:precompile --trace
** Invoke assets:precompile (first_time)
** Execute assets:precompile
"C:/Program Files/ruby-1.9.2/bin/ruby.exe" C:/Program Files/ruby-1.9.2/bin/rake assets:precompile:all RAILS_ENV=producti
on RAILS_GROUPS=assets --trace
rake aborted!
Command failed with status (127): ["C:/Program Files/ruby-1.9.2/bin/ruby.exe"...]
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/file_utils.rb:53:in `block in create_shell_ru
nner"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/file_utils.rb:45:in `call"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/file_utils.rb:45:in `sh"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/file_utils_ext.rb:39:in `sh"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/file_utils.rb:80:in `ruby"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/file_utils_ext.rb:39:in `ruby"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/actionpack-3.2.6/lib/sprockets/assets.rake:12:in `ruby_rake_task"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/actionpack-3.2.6/lib/sprockets/assets.rake:21:in `invoke_or_reboot_
rake_task"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/actionpack-3.2.6/lib/sprockets/assets.rake:29:in `block (2 levels)
in <top (required)>"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `call"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `block in execute"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `each"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `execute"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:158:in `block in invoke_with_call_cha
in"
C:/Program Files/ruby-1.9.2/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:144:in `invoke"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:116:in `invoke_task"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `block (2 levels) in top
_level"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `each"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `block in top_level"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_han
dling"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:88:in `top_level"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:66:in `block in run"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_han
dling"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run"
C:/Program Files/ruby-1.9.2/lib/ruby/gems/1.9.1/gems/rake-0.9.2.2/bin/rake:33:in `<top (required)>"
C:/Program Files/ruby-1.9.2/bin/rake:19:in `load"
C:/Program Files/ruby-1.9.2/bin/rake:19:in `<main>"
Tasks: TOP => assets:precompile

क्या किसी को यह पता है कि इसे कैसे ठीक किया जाए? अग्रिम में धन्यवाद।

उत्तर:

जवाब के लिए 0 № 1

स्टेटस कोड 127 आमतौर पर "कमांड नहीं मिला" इंगित करने के लिए प्रयोग किया जाता है। आपके मामले में ["C:/Program Files/ruby-1.9.2/bin/ruby.exe"...], ruby.exe नहीं मिला है। क्या आपने रूबी को ठीक से स्थापित किया था?


संबंधित सवाल
सबसे लोकप्रिय