Problèmes de chargement de certains styles CSS avec Internet Explorer accédant à partir du nom de l'ordinateur - javascript, css, internet-explorer, iis-7, web

Je rencontre un problème très étrange uniquement avec Internet Explorer (j’utilise la version 9.0.8)

J'ai un serveur Web installé sur l'ordinateur (Windows 7) fonctionnant sous IIS 7. J'ai utilisé l'infrastructure CakePHP pour le site.

Lorsque j'y accède à partir de mon adresse IP, tout fonctionne bien, mais d'un autre côté, lorsque j'y accède à partir du nom de l'ordinateur, certains styles CSS ne sont pas appliqués, de même que certains scripts JS.

Les fichiers se chargent correctement car la plupart des styles CSS sont appliqués et tous se chargent à partir du même fichier. Mais certains d’entre eux, ne me demandez pas pourquoi, ne sont pas appliqués.

Ici, vous pouvez consulter l'inspecteur Internet Explorer chargeant le site à partir des deux URL: http://s9.postimage.org/vjhg6ytsd/problem.png entrez la description de l'image ici

Avec Javascript, ce qui se passe est que certainsles fonctions semblent interrompre le flux du reste. Si je supprime ces fonctions "conflictuelles", alors cela fonctionne bien. (mais ça marche toujours bien en le chargeant depuis localhost ou directement avec l'IP ...)

Réponses:

2 pour la réponse № 1

Voir: IE ne rend pas le code CSS correctement lorsque le site est situé sur un lecteur réseau.

Ajoute ça:

<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

2 pour la réponse № 2

Voir: IE ne rend pas le code CSS correctement lorsque le site est situé sur un lecteur réseau.

Ajoute ça:

<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

questions connexes
Menu