Erreur de compilation avec ios-charts - ios, swift, ios-frameworks, ios-charts

J'ai suivi le guide ici installer le framework ios-charts en tant quebinaire intégré et l'étape 3 du guide me demande de construire le projet. La construction échoue alors instantanément à la suite de l'ajout du binaire incorporé. J'ai téléchargé la version la plus récente du framework, et il est supposé compatible avec swift 3.

J'utilise X-code 8 bêta, et donc rapide 3. Est-ce que quelqu'un peut me pointer dans la bonne direction?

entrez la description de l'image ici

Réponses:

2 pour la réponse № 1
  1. Télécharger fichier zip avec projet

  2. Construit le

  3. Dans Xcode trouver le dossier du produit, trouver le produit des graphiques, afficher dans le Finder
  4. Ouvrez votre projet en xCode
  5. Glissez et déposez le paquet (de l'étape 3) à votre projet en xCode
  6. Configurez les paramètres de votre projet: dans les binaires intégrés, utilisez "+" pour ajouter des graphiques

0 pour la réponse № 2

1) Utilisez CocoaPods (doc: https://cocoapods.org)

2) Ajouter des graphiques à votre fichier pod (doc: https://github.com/danielgindi/Charts)

Ajoutez un pod "Charts" à votre fichier Podfile. "Charts" est le nom de la bibliothèque.

Pour le support de domaine, vous pouvez spécifier le sous-sujet dans votre fichier Podfile comme suit:

pod "Cartes / Royaume"

Remarque: pod "ios-charts" n'est pas la bonne bibliothèque, et fait référence à un projet différent par quelqu'un d'autre.


-1 pour la réponse № 3

Pour Swift 3, vous devriez aller avec CocoaPods.

Écrire pod "Charts/Realm" cela va installer la version exacte de pod pour le graphique, puis nettoyer et construire.


Menu