IPC con Ruby 1.8.5 - ruby, ipc, sketchup

Necesito hacer IPC con Ruby 1.8.5. El problema es que es el Ruby el que se envía con Google SketchUp, y es solo un subconjunto de la API Ruby completa. Por ejemplo, no hay clases Socket ni DRb.

¿Cuáles son algunas otras formas de hacer IPC con Ruby?¿Algo que use la clase File, como archivos mapeados en memoria, o algo así? Soy completamente nuevo en IPC, así que me disculpo si me perdí algo obvio.

Respuestas

0 para la respuesta № 1

La última versión de SketchUp se envía con Ruby 1.8.6. Puedes descargar (si no lo has hecho ya) la API básica de Ruby, y solo require cualesquiera archivos que necesite, para implementar su script.

Probar código que no sea de SketchUp Ruby es mucho más fácil fuera de SketchUp, con la línea de comandos o con un editor como SciTE. Luego puede agregar su código de SketchUp para las pruebas dentro de la aplicación.

Ruby Descargar

SciTE Descargar


Menú