IPC mit Ruby 1.8.5 - Ruby, IPC, Sketchup

Ich muss IPC mit Ruby 1.8.5 machen. Der Catch ist, dass es der Ruby ist, der mit Google SketchUp ausgeliefert wird und nur eine Teilmenge der vollständigen Ruby-API ist. So gibt es zum Beispiel keine Socket-Klasse und keinen DRb.

Was sind andere Wege, IPC mit Ruby zu machen?Alles, was die File-Klasse verwendet, wie zum Beispiel Speicherkarten oder ähnliches? Ich bin komplett neu für IPC, also entschuldige ich mich, wenn ich etwas Offensichtliches verpasst habe.

Antworten:

0 für die Antwort № 1

Die neueste Version von SketchUp wird mit Ruby 1.8.6 ausgeliefert. Sie können die Kern-Ruby-API herunterladen (wenn Sie das nicht bereits getan haben) require welche Dateien Sie benötigen, um Ihr Skript zu implementieren.

Nicht-SketchUp-Ruby-Code zu testen, ist außerhalb von SketchUp, mit der Befehlszeile oder einem Editor wie SciTE viel einfacher. Dann können Sie Ihren SketchUp-Code für Tests innerhalb der Anwendung hinzufügen.

Ruby herunterladen

SciTE Download


Speisekarte